<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
  
    <title>Southside Pride &#8211; A new police chief?</title>

	<link rel="stylesheet" type="text/css" href="http://southsidepride.com/wp-content/themes/zenko2.2/style.css" media="screen" />
	<!--[if IE 7]><link rel="stylesheet" type="text/css" href="http://southsidepride.com/wp-content/themes/zenko2.2/ie7.css" /><![endif]-->
	<!--[if IE 6]><link rel="stylesheet" type="text/css" href="http://southsidepride.com/wp-content/themes/zenko2.2/ie6.css" /><![endif]-->
	      
    <link rel="pingback" href="http://southsidepride.com/xmlrpc.php" />

    <link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Southside Pride &raquo; Feed" href="http://southsidepride.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Southside Pride &raquo; Comments Feed" href="http://southsidepride.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Southside Pride &raquo; A new police chief? Comments Feed" href="http://southsidepride.com/a-new-police-chief-2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/southsidepride.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='form-manager-css-css'  href='http://southsidepride.com/wp-content/plugins/wordpress-form-manager/css/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='otw_grid_manager-css'  href='http://southsidepride.com/wp-content/plugins/widgetize-pages-light/include/otw_components/otw_grid_manager/css/otw-grid.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='general_foundicons-css'  href='http://southsidepride.com/wp-content/plugins/widgetize-pages-light/include/otw_components/otw_shortcode/css/general_foundicons.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social_foundicons-css'  href='http://southsidepride.com/wp-content/plugins/widgetize-pages-light/include/otw_components/otw_shortcode/css/social_foundicons.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='otw_shortocde-css'  href='http://southsidepride.com/wp-content/plugins/widgetize-pages-light/include/otw_components/otw_shortcode/css/otw_shortcode.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-css'  href='http://southsidepride.com/wp-content/plugins/image-formatr/src/prettyPhoto.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='mbpro-font-awesome-css'  href='http://southsidepride.com/wp-content/plugins/maxbuttons/assets/libraries/font-awesome/css/font-awesome.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='ssbaFont-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='tab-me-styles-css'  href='http://southsidepride.com/wp-content/plugins/tab-me/tab-me.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpz-shortcodes-css'  href='http://southsidepride.com/wp-content/themes/zenko2.2/functions/wpzoom/assets/css/shortcodes.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-font-awesome-css'  href='http://southsidepride.com/wp-content/themes/zenko2.2/functions/wpzoom/assets/css/font-awesome.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wzslider-css'  href='http://southsidepride.com/wp-content/themes/zenko2.2/functions/wpzoom/assets/css/wzslider.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css'  href='http://southsidepride.com/wp-content/themes/zenko2.2/custom.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='http://southsidepride.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.7.7' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://southsidepride.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.7.7' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://southsidepride.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.7.7' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='myStyleSheets-css'  href='http://southsidepride.com/wp-content/plugins/wp-frontpage-news/css/wpcufpn_front.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='tw-recent-posts-widget-css'  href='http://southsidepride.com/wp-content/plugins/tw-recent-posts-widget/tw-recent-posts-widget.css?ver=1.0.5' type='text/css' media='screen' />
<script type='text/javascript'>
/* <![CDATA[ */
var fm_user_I18n = {"ajaxurl":"http:\/\/southsidepride.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/wordpress-form-manager/js/userscripts.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/southsidepride.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mb_ajax = {"ajaxurl":"http:\/\/southsidepride.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/maxbuttons/js/min/front.js?ver=1'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/themes/zenko2.2/js/init.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://southsidepride.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://southsidepride.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://southsidepride.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel="canonical" href="http://southsidepride.com/a-new-police-chief-2/" />
<link rel='shortlink' href='http://southsidepride.com/?p=5445' />
<link rel="alternate" type="application/json+oembed" href="http://southsidepride.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsouthsidepride.com%2Fa-new-police-chief-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://southsidepride.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsouthsidepride.com%2Fa-new-police-chief-2%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.5 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { min-width:1px; max-width:152px; }
	.b-3 { margin:1px; }
	.g-4 { min-width:1px; max-width:152px; }
	.b-4 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									
								}
								</style>
<!-- Protected by WP-SpamFree :: JS BEGIN -->
<script type="text/javascript" src="http://southsidepride.com/wp-content/plugins/wp-spamfree/js/wpsfv2-js.php"></script> 
<!-- Protected by WP-SpamFree :: JS END -->

<!-- WPZOOM Theme / Framework -->
<meta name="generator" content="Zenko Magazine 2.1.8" />
<meta name="generator" content="WPZOOM Framework 1.6.6" />
<style type="text/css">@import url("http://fonts.googleapis.com/css?family=Changa+One");
body{background-color:#ffffff;}
.widget h3.title{color:#ffffff;}
#slider h2 a{font-family: Arial;}.widget h3.title{font-family: 'Changa One';font-size: 14px;font-style: italic;}</style>
<!-- BEGIN GADWP v5.1.1.1 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-100775025-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
 </head>
<body class="post-template-default single single-post postid-5445 single-format-standard">
 
	<div id="header">

<!-- <table style="float:left; width:980px">
<tr>
<td width="41px"><span class='mb-center maxbutton-1-center'><span class='maxbutton-1-container mb-container'><a class="maxbutton-1 maxbutton maxbutton-home" href="http://www.southsidepride.com"><span class='mb-text'>HOME</span></a></span></span></td>
<td width="46px"><span class='mb-center maxbutton-2-center'><span class='maxbutton-2-container mb-container'><a class="maxbutton-2 maxbutton maxbutton-about" href="/about"><span class='mb-text'>ABOUT</span></a></span></span></td>
<td width="59px"><span class='mb-center maxbutton-3-center'><span class='maxbutton-3-container mb-container'><a class="maxbutton-3 maxbutton maxbutton-contact" href="/contact"><span class='mb-text'>CONTACT</span></a></span></span></td>
<td width="68px"><span class='mb-center maxbutton-4-center'><span class='maxbutton-4-container mb-container'><a class="maxbutton-4 maxbutton maxbutton-advertise" href="/advertise"><span class='mb-text'>ADVERTISE</span></a></span></span></td>
<td width="70px"><span class='mb-center maxbutton-5-center'><span class='maxbutton-5-container mb-container'><a class="maxbutton-5 maxbutton maxbutton-subscribe" href="/subscribe"><span class='mb-text'>SUBSCRIBE</span></a></span></span></td>
<td width="84px"><span class='mb-center maxbutton-6-center'><span class='maxbutton-6-container mb-container'><a class="maxbutton-6 maxbutton maxbutton-unsubscribe" href="/unsubscribe"><span class='mb-text'>UNSUBSCRIBE</span></a></span></span></td>
<td width="77px"><span class='mb-center maxbutton-7-center'><span class='maxbutton-7-container mb-container'><a class="maxbutton-7 maxbutton maxbutton-classifieds" href="/classifieds"><span class='mb-text'>CLASSIFIEDS</span></a></span></span></td>
<td width="50px"><span class='mb-center maxbutton-8-center'><span class='maxbutton-8-container mb-container'><a class="maxbutton-8 maxbutton maxbutton-submit" href="/submit"><span class='mb-text'>SUBMIT</span></a></span></span></td>
<td width="485px"><p align="right" style="font-size:11px;color:#196385;"></strong>612-822-4662 | 3200 Chicago Avenue, Minneapolis, MN 55407</strong></p></td>
</tr>
</table>-->
<div class="top-header-buttons">
	<ul>
		<li><a href="http://southsidepride.com">Home</a></li>
		<li><a href="http://southsidepride.com/about/">About Us</a></li>
		<li><a href="http://southsidepride.com/advertise/">Advertise</a></li>
		<li><a href="http://southsidepride.com/subscribe/">Subscribe<a/></li>
		<li><a href="http://southsidepride.com/classifieds/">Classifieds</a></li>
		<li><a href="http://southsidepride.com/submit/">Submit</a></li>
                <li>&nbsp;</li>
		<li class="last">612-822-4662 | 3200 Chicago Avenue, Minneapolis, MN 55407</li>
	</ul>
</div>

<br />
<div style="padding-top: 20px;"><div class="g g-1"><div class="g-single a-13"><span style="margin-top: 20px"><a class="gofollow" data-track="MTMsMSwxLDYw" href="http://wheelfunrentals.com/"><img  src="http://southsidepride.com/wp-content/uploads/2017/05/Wheel-Fun-Top-Banner2016.jpg" /></a></span></div></div></div>
	
		<div id="logo">
						
						<a href="http://southsidepride.com" title="Serving Phillips/Powderhorn, Nokomis &amp; Riverside">
															<img src="http://southsidepride.com/wp-content/uploads/2013/12/Logo.jpg" alt="Southside Pride" />
													</a>

						<br/><div class="otw-sidebar otw-sidebar-1 otw-sidebar-vertical"><div class="widget otw-widget-1 widget-first widget_shortcodeui"><p style="font-size: 11px; color: #f62a27;" align="center">NOKOMIS EDITION (2nd Monday) August 2017, VOL. XXVII, ISSUE 23</p>
<!-- Simple Share Buttons Adder (6.3.6) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left">Share this on Facebook.<a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://southsidepride.com/a-new-police-chief-2/"  target="_blank" ><img src="http://southsidepride.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a></div></div><span style="clear:both;display:none;"><img src="http://southsidepride.com/wp-content/plugins/wp-spamfree/img/wpsf-img.php" width="0" height="0" alt="" style="border-style:none;width:0px;height:0px;display:none;" /></span> </div></div>        </div>

	<!-- HALF BANNER -->
	<center><div style="padding-top:40px;" align="right"><div class="g g-2"><div class="g-single a-12"><a class="gofollow" data-track="MTIsMiwxLDYw" href="http://southsidepride.com/wp-content/uploads/2017/08/pp-chicago-ave-fall-section_flat.pdf"><img src="http://southsidepride.com/wp-content/uploads/2017/08/fall-09-14.jpg" /></a></div></div></div></center>
	<!-- HALF BANNER -->

		
		<div class="clear"></div>
		
	</div>

	<div id="menu">
		<div id="menu-wrap">
 			<ul id="mainmenu" class="dropdown"><li id="menu-item-956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-956"><a href="http://southsidepride.com/back-issues-2/">Archives</a></li>
<li id="menu-item-75" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75"><a target="_blank" href="http://archive.southsidepride.com/archives/index.html">Before 2014 Archive</a></li>
</ul>
				 			<div id="rss_icon">
	 				 <a href="http://southsidepride.com/feed/"></a> 
	 			</div>
 			 		
			<div id="search"> 
	<form method="get" id="searchform" action="http://southsidepride.com/">
		<input type="text" name="s" id="se" size="35" onblur="if (this.value == '') {this.value = 'SEARCH';}" onfocus="if (this.value == 'SEARCH') {this.value = '';}" value="SEARCH" class="text" />
		<input type="submit" id="searchsubmit" class="submit" value="Search" />
	</form>
</div> 			
		</div> <!-- /#menu-wrap -->
    
    </div> <!-- /#menu -->
     
 	<div id="content-wrap">
		<div id="content">
 	<div id="middle">

		<div id="post-5445" class="post-5445 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-nokomis category-phillips-powderhorn category-riverside">

			
				<h1><a href="http://southsidepride.com/a-new-police-chief-2/" rel="bookmark">A new police chief?</a></h1>

				<div class="post-meta">
					in <a href="http://southsidepride.com/category/news/" rel="category tag">News</a>, <a href="http://southsidepride.com/category/news/nokomis/" rel="category tag">Nokomis</a>, <a href="http://southsidepride.com/category/news/phillips-powderhorn/" rel="category tag">Phillips/Powderhorn</a>, <a href="http://southsidepride.com/category/news/riverside/" rel="category tag">Riverside</a> / 					by <a href="http://southsidepride.com/author/ashley/" title="Posts by Ashley Pederson" rel="author">Ashley Pederson</a> / 					on August 14, 2017 at 1:59 pm / 									</div>

				              <div  class="img alignleft size-full wp-image-5393" style="width:{$img_width}px">
                                <a
                  href="http://southsidepride.com/wp-content/uploads/2017/08/c31b94511830624344375bffd57e7ad3-e1502132552334.png"
                  title=""
                                  rel="prettyPhoto[]"
                >                  <img src="http://southsidepride.com/wp-content/uploads/2017/08/c31b94511830624344375bffd57e7ad3-e1502132552334.png" alt="" style="max-width: 180px; " title="Click here to enlarge."/></a>
                
              </div>BY ED FELIEN</p>
<p>We do not need a change of the Palace Guard. Replacing the chief of police is not the solution to the problem with the Minneapolis Police Department. The problem is there is no accountability. The MPD officers believe they are above the law. They believe their badge and their gun makes them the law. Their recently re-elected leader, Lt. Bob Kroll, is the leader of City Heat, the neo-Nazi motorcycle gang. He has been sued by black members of the MPD (including the chief designate) for racist behavior. He has been prosecuted for use of excessive force as a member of a tactical squad special unit. He is the public face of the MPD.</p>
<p><strong>Here are five actions that must be taken to restore confidence in the MPD:</strong></p>
<p>1. The actions of the MPD must be subject to review by the Minneapolis Civil Rights Commission. Every other employee in Minneapolis, every other citizen or visitor to Minneapolis is subject to the civil rights ordinances of Minneapolis. The MPD are exempt. This tells them they are above the law. This can be changed by an action of the City Council.</p>
<p>2. There must be a full review of the police reports of the Jamar Clark and Terrance Franklin killings by the Minnesota attorney general and the Minnesota Civil Rights Commission. This must be requested by the mayor and City Council. Even a superficial reading of the reports reveal obvious examples of police misconduct. Officers responsible for misconduct must be held accountable.</p>
<p>3. There must be a public review of the training of MPD officers. The training films of the discredited Lewinsky that encourage a “Shoot first, ask questions later” must be stopped and repudiated.</p>
<p>4. We need a much greater reliance on block clubs to maintain public order. In especially troubled neighborhoods, the city should pay block club captains to act as welcome wagon hosts for new residents, telling them about government services, educational and employment opportunities.</p>
<p>5. There must be a residency requirement for all city employees. The MPD must “Protect and Serve” all the people who live in this city. They are not an occupying army.</p>
<p><strong>Jeremy Schroeder, a candidate for City Council for the 11th Ward, responds:</strong></p>
<p>Minneapolis needs to take more expansive action than simply replacing our police chief. We need to foster greater accountability of our police officers and their leadership to ensure real change gets made.  Heightened tensions between the community and police are not good for anyone. We need change now.<br />
There absolutely must be public review of the training of MPD officers. We need to review our standards for recruitment, the training curriculum itself, and the graduation standard for the police academy. It is also vital that the police department expand its commitment to de-escalation and implicit bias training, and make sure that training translates to results in the field.<br />
I am supportive of efforts to appoint a block captain on every block in our city, and like the idea of better defining these community members’ important role. Block captains serve as an important link between community members and the police department, and we have a significant opportunity to leverage those relationships to build trust and relationships between police and our neighbors. When block captains work with neighborhood groups, this system can have an even bigger impact. In my experience serving on the Hale Page Diamond Lake Neighborhood Association, we’ve struggled to get in touch with block captains because of privacy concerns. We fully respect that, but there needs to be a middle ground that enables us to get block captains more involved in neighborhood business so we can share resources and cooperate.<br />
A disturbingly low number of Minneapolis police officers actually live in the city, and that needs to change. Living in the community they serve would give officers a deeper understanding of the issues they face. We need to do everything we can to discourage unfair and uninformed biases, and requiring police officers to work closer to home is an important starting point. It gives them a bigger stake in the community—something our city needs, especially now.</p>
<!-- Simple Share Buttons Adder (6.3.6) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left">Share this on Facebook.<a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://southsidepride.com/a-new-police-chief-2/"  target="_blank" ><img src="http://southsidepride.com/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a></div></div><span style="clear:both;display:none;"><img src="http://southsidepride.com/wp-content/plugins/wp-spamfree/img/wpsf-img.php" width="0" height="0" alt="" style="border-style:none;width:0px;height:0px;display:none;" /></span> 				<div class="clear"></div>

				
				
 									<div class="share_box">
						<div class="share_btn"><g:plusone size="medium"></g:plusone></div>
 						<div class="share_btn"><a href="http://twitter.com/share" data-url="http://southsidepride.com/a-new-police-chief-2/" class="twitter-share-button" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
						<div class="share_btn"><iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fsouthsidepride.com%2Fa-new-police-chief-2%2F&amp;layout=button_count&amp;show_faces=false&amp;width=1000&amp;action=like&amp;font=arial&amp;colorscheme=light&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:80px; height:21px;" allowTransparency="true"></iframe></div>
 							<div class="clear"></div>
					</div>
				
 									<div id="comments">
						


			<!-- If comments are open, but there are no comments. -->

	  
	  
          <!-- comment form --> 
 
<div id="respond">

	<h3>Leave a Comment</h3>
 
<div class="cancel-comment-reply">
	<a rel="nofollow" id="cancel-comment-reply-link" href="/a-new-police-chief-2/#respond" style="display:none;">Click here to cancel reply.</a></div>


<form action="http://southsidepride.com/wp-comments-post.php" method="post" id="commentform">


<p><input class="field" type="text" name="author" id="author" value="" size="22" tabindex="1" />
<label for="author"><small>Name  (required)</small></label></p>

<p><input class="field" type="text" name="email" id="email" value="" size="22" tabindex="2" />
<label for="email"><small>Email (will not be published)  (required)</small></label></p>

<p><input class="field" type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p>


 

<p><textarea class="field" name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" class="bgCH submit btn" tabindex="5" value="Add Reply" />
<input type='hidden' name='comment_post_ID' value='5445' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
	<script type='text/javascript'>
	<!--
	refJS = escape( document[ 'referrer' ] );
	document.write("<input type='hidden' name='refJS' value='"+refJS+"'>");
	// -->
	</script>
	
</form>


</div>    <!-- /comment form -->
 

 					</div>
				
 			
		</div> <!-- /#post -->

	</div> <!-- /#middle -->

<div id="sidebar">

		
	
	<div id="tw-recent-posts-2" class="widget tw-recent-posts"><h3 class="title"><a href="/category/community-calendar/">Community Calendar »</a></h3>
<div class="featured-posts textwidget">
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/events/" rel="bookmark" title="Events">
                Events            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/community/" rel="bookmark" title="Community News">
                Community News            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/theater/" rel="bookmark" title="Theater &#038; Film">
                Theater &#038; Film            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/music/" rel="bookmark" title="Music &#038; Dance">
                Music &#038; Dance            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/art/" rel="bookmark" title="Art">
                Art            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/annoucements/" rel="bookmark" title="Announcements">
                Announcements            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
</div>
<div class="clear"></div></div><div id="tw-recent-posts-3" class="widget tw-recent-posts"><h3 class="title"><a href="/category/religion-calendar/">Religion Calendar »</a></h3>
<div class="featured-posts textwidget">
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/announcements/" rel="bookmark" title="Announcements">
                Announcements            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/ongoing/" rel="bookmark" title="Ongoing">
                Ongoing            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/events-2/" rel="bookmark" title="Events">
                Events            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
	<div class="featured-post">

			<h4>
            <a href="http://southsidepride.com/consider-this/" rel="bookmark" title="Consider this">
                Consider this            </a>
        </h4>
	
	
	
	
		<div class="clear"></div>
	</div>
</div>
<div class="clear"></div></div> 
		
	<div id="sidebar_left">
		<div id="text-2" class="widget widget_text">			<div class="textwidget"><!--[adrotate banner="7"]
[adrotate banner="8"]-->
<div class="g g-3"><div class="g-col b-3 a-23"><a href="http://southsidepride.com/wp-content/uploads/2017/05/Spirit-and-Conscience-for-Website-2016-1.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2016/09/Spirit-Conscience-copy.jpg" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-21"><a href="http://southsidepride.com/wp-content/uploads/2016/03/Felien-11-09-15-Confessions-complete.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2016/03/ED-ARRESTED-website.jpg" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-8"><a class="gofollow" data-track="OCwzLDEsNjA=" href="http://minnehahaacademy.net"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2014/01/minnehahaacademy.jpg" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-22"><a href="http://www.minneapolismn.gov/www/groups/public/@publicworks/documents/webcontent/wcmsp-198170.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2017/05/wATER-qUALITY.jpg" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-9"><a class="gofollow" data-track="OSwzLDEsNjA=" href="http://seward.coop"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2014/01/seward.jpg" /></a></div></div><div class="g g-3"><div class="g-col b-3 a-7"><a class="gofollow" data-track="NywzLDEsNjA=" href="http://www.mpls.k12.mn.us"><img width="100%" src="http://southsidepride.com/wp-content/uploads/2014/01/mpls_public.jpg" /></a></div></div>
</div>
		<div class="clear"></div></div>	</div> <!-- end side left -->
 
	<div id="sidebar_right">
		<div id="text-3" class="widget widget_text">			<div class="textwidget"><!--[adrotate banner="9"]--></div>
		<div class="clear"></div></div><div id="adrotate_widgets-3" class="widget adrotate_widgets"><div class="g g-4"><div class="g-col b-4 a-19"><a class="gofollow" data-track="MTksNCwxLDYw" href="http://southsidepride.com/wp-content/uploads/2015/06/Felien-Mitch-and-John-for-website.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2015/06/Mitch-John-website1.jpg" /></a></div></div><div class="g g-4"><div class="g-col b-4 a-16"><a class="gofollow" data-track="MTYsNCwxLDYw" href="http://southsidepride.com/wp-content/uploads/2015/03/Terrance-Franklin-ebook.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2015/03/Terrance.jpg" /></a></div></div><div class="g g-4"><div class="g-col b-4 a-17"><a class="gofollow" data-track="MTcsNCwxLDYw" href="http://southsidepride.com/wp-content/uploads/2016/03/Johnny-Hazard-dispatches-from-Mexico.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2015/04/Johnny-Hazard1.jpg" /></a></div></div><div class="g g-4"><div class="g-col b-4 a-14"><a class="gofollow" data-track="MTQsNCwxLDYw" href="http://southsidepride.com/wp-content/uploads/2014/07/Polly-Mann-ebook.pdf"><img width="100%"  src="http://southsidepride.com/wp-content/uploads/2014/07/Polly-Cover.jpg" /></a>
</div></div><div class="clear"></div></div>	</div> <!-- end side right -->
 
 
		 
</div> <!-- /#sidebar -->	</div> <!-- /#content -->
</div> <!-- /#content-wrap -->
<div id="footer">

	<div class="footer-wrap">
  
		<div id="fside">
			<div class="column">
			   			</div><!-- /1st column -->
		  
			<div class="column">
			   			</div><!-- /2nd column -->
			
			<div class="column">
			   			</div><!-- /3rd column -->
			
			<div class="column last">
			   			</div><!-- /4th column -->
 		</div>
		
	</div> <!-- /#footer-wrap-->
	
	<div class="clear"></div>      
				  
	<div id="copyright">
	  
		<div class="footer-wrap">
			Copyright &copy; 2017 &mdash; <a href="http://southsidepride.com/" class="on">Southside Pride</a>. All Rights Reserved.<br />
			<span><!--DESIGNED BY --></span>
			
		</div> <!-- /#footer-wrap-->
		
	</div>
	
</div> <!-- /#footer -->

<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>

<script type="text/javascript" charset="utf-8">
  jQuery(document).ready(function(){
    jQuery("a[rel^='prettyPhoto']").prettyPhoto({
        social_tools: false,
        theme: 'pp_default',
        animation_speed: 'slow'
    });
  });
</script>
<!--email_off--><style type='text/css'>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</style><!--/email_off-->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-46421419-1', 'southsidepride.com');
  ga('send', 'pageview');

</script><script>(function($){$(document).ready(function(){});})(jQuery);</script><script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/image-formatr/src/prettyPhoto.js?ver=3.1.4'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/tab-me/tab-me.js'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/themes/zenko2.2/js/dropdown.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/themes/zenko2.2/functions/wpzoom/assets/js/galleria.js'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/themes/zenko2.2/functions/wpzoom/assets/js/wzslider.js'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-content/plugins/wp-frontpage-news/js/wpcufpn_front.js?ver=0.1'></script>
<script type='text/javascript' src='http://southsidepride.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
 


</body>
</html>
